BoundingBoxIsInsideFilter(Outline, Double) Constructor |
Constructs a new instance of a filter to match elements with a bounding box that is contained by the given Outline.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic BoundingBoxIsInsideFilter(
Outline outline,
double tolerance
)
Public Sub New (
outline As Outline,
tolerance As Double
)
public:
BoundingBoxIsInsideFilter(
Outline^ outline,
double tolerance
)
new :
outline : Outline *
tolerance : float -> BoundingBoxIsInsideFilter
Parameters
- outline Outline
-
The Outline used to find elements with a bounding box that are contained by it.
- tolerance Double
-
The tolerance value to use instead of zero. See the tolerance property for details.
ExceptionsException | Condition |
---|
ArgumentException |
outline is an empty Outline.
-or-
The given value for tolerance is not finite
-or-
The given value for tolerance is not a number
|
ArgumentNullException |
A non-optional argument was null
|
See Also