ViewScheduleSetSegmentHeight Method |
Sets the segment height.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetSegmentHeight(
int segmentIndex,
double height
)
Public Sub SetSegmentHeight (
segmentIndex As Integer,
height As Double
)
public:
void SetSegmentHeight(
int segmentIndex,
double height
)
member SetSegmentHeight :
segmentIndex : int *
height : float -> unit
Parameters
- segmentIndex Int32
-
Index of the segment.
- height Double
-
New height for the segment.
Exceptions
Remarks
The height is Revit's internal units value of schedule header and segment body.
The last segment can not set height. Its height will be determined by whole schedule height and other segments' heights.
The height will not be the exact segment height on sheet. It will be the border height of the instance. The real height
will be determined by the segment content. If the row cannot be shown within the instance boder, it will flow to the next segment.
See Also