LinearArrayIsValidNumberOfMembers Method

This indicates whether the input count is a valid size for an array based on the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool IsValidNumberOfMembers(
	int count,
	Document pADoc
)

Parameters

count  Int32
The count.
pADoc  Document
The document.

Return Value

Boolean
True if an array can be set to the specified count in the given document, false otherwise.
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
Remarks
In project documents, the array count must be between 2 and 200. In family documents, the array count must be between 0 and 200.
See Also