HostObjAttributesGetCompoundStructure Method |
Returns an object that represents the compound structure of the element.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic CompoundStructure GetCompoundStructure()
Public Function GetCompoundStructure As CompoundStructure
public:
CompoundStructure^ GetCompoundStructure()
member GetCompoundStructure : unit -> CompoundStructure
Return Value
CompoundStructure
RemarksA copy of the compound structure is returned and changes made to it will not apply to the type until SetCompoundStructure is called.
From this object the layers of a compound structure can be accessed. If the element does
not have a compound structure then this method will return .
See Also