CustomFieldDataSetCustomFieldProperties Method

Sets an instance of ICustomFieldProperties which represents the properties of this field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetCustomFieldProperties(
	ICustomFieldProperties customFieldProperties
)

Parameters

customFieldProperties  ICustomFieldProperties
An instance of ICustomFieldProperties which represents the properties of this field.
Exceptions
ExceptionCondition
ArgumentException The input properties are not valid.
ArgumentNullException A non-optional argument was null
InvalidOperationException Can't set the properties to a CustomFieldData of a SchedulableField (which is not added to a schedule).
See Also