SheetCollectionCreate(Document) Method |
Creates a new instance of sheet collection with an auto-generated name and adds it to the document.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static SheetCollection Create(
Document document
)
Public Shared Function Create (
document As Document
) As SheetCollection
public:
static SheetCollection^ Create(
Document^ document
)
static member Create :
document : Document -> SheetCollection
Parameters
- document Document
-
The document where the sheet collection element will be created and added.
Return Value
SheetCollection
The newly created sheet collection element.
ExceptionsException | Condition |
---|
ArgumentNullException |
A non-optional argument was null
|
InvalidOperationException |
The document is in failure mode: an operation has failed,
and Revit requires the user to either cancel the operation
or fix the problem (usually by deleting certain elements).
|
ModificationForbiddenException |
The document is in failure mode: an operation has failed,
and Revit requires the user to either cancel the operation
or fix the problem (usually by deleting certain elements).
-or-
The document is being loaded, or is in the midst of another
sensitive process.
|
ModificationOutsideTransactionException |
The document has no open transaction.
|
See Also