IGetLocalPathForOpenCallbackGetLocalPathForOpen Method |
Implement this method to specify the local path from where a copy of a Revit link external resource can be opened
for modification without interfering with its use as a link in other open documents.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxstring GetLocalPathForOpen(
ExternalResourceReference desiredResource
)
Function GetLocalPathForOpen (
desiredResource As ExternalResourceReference
) As String
String^ GetLocalPathForOpen(
ExternalResourceReference^ desiredResource
)
abstract GetLocalPathForOpen :
desiredResource : ExternalResourceReference -> string
Parameters
- desiredResource ExternalResourceReference
-
The ExternalResourceReference that needs to be opened for modification by Revit.
Return Value
String
The local path from where Revit can open the linked file as its own top-level document.
See Also