StructuralFramingUtilsCanSetEndReference Method |
Determines if a reference can be set for the given end of the framing element.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool CanSetEndReference(
FamilyInstance familyInstance,
int end
)
Public Shared Function CanSetEndReference (
familyInstance As FamilyInstance,
end As Integer
) As Boolean
public:
static bool CanSetEndReference(
FamilyInstance^ familyInstance,
int end
)
static member CanSetEndReference :
familyInstance : FamilyInstance *
end : int -> bool
Parameters
- familyInstance FamilyInstance
-
The FamilyInstance, which must be of a structural framing category, non-concrete and joined at the given end.
- end Int32
-
The index of the end (0 for the start, 1 for the end).
Return Value
Boolean
True if reference can be set for the given end of the framing element.
Exceptions
See Also