CompoundStructureGetSegmentOrientation Method |
Gets the orientation of a segment.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic RectangularGridSegmentOrientation GetSegmentOrientation(
int segmentId
)
Public Function GetSegmentOrientation (
segmentId As Integer
) As RectangularGridSegmentOrientation
public:
RectangularGridSegmentOrientation GetSegmentOrientation(
int segmentId
)
member GetSegmentOrientation :
segmentId : int -> RectangularGridSegmentOrientation
Parameters
- segmentId Int32
-
The id of a segment in this CompoundStructure.
Return Value
RectangularGridSegmentOrientation
The orientation of the specified segment.
Exceptions
Remarks
The boundaries of the regions of a vertically compound structure consist of vertical
horizontal segments.
See Also