TableSectionDataNumberOfRows Property |
Gets or sets the number of items in row data array.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic int NumberOfRows { get; set; }
Public Property NumberOfRows As Integer
Get
Set
public:
property int NumberOfRows {
int get ();
void set (int value);
}
member NumberOfRows : int with get, set
Property Value
Int32
ExceptionsException | Condition |
---|
InvalidOperationException |
When setting this property: This operation is forbidden for cells in standard schedule body sections.
|
Remarks
Note that TableSections may use either 0 or 1 as the first row and column indices. To access the rows and columns:
- Use FirstRowNumber and LastRowNumber to get the valid range of row indices.
- Use FirstColumnNumber and LastColumnNumber to get the valid range of column indices.
See Also