ModelPathUtilsIsValidUserVisibleFullServerPath Method |
Determines whether the given string represents a valid
server path.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool IsValidUserVisibleFullServerPath(
string strPath
)
Public Shared Function IsValidUserVisibleFullServerPath (
strPath As String
) As Boolean
public:
static bool IsValidUserVisibleFullServerPath(
String^ strPath
)
static member IsValidUserVisibleFullServerPath :
strPath : string -> bool
Parameters
- strPath String
-
The path, in string form
Return Value
Boolean
True if the given path is a valid server path, false otherwise.
Exceptions
RemarksServerPaths must refer to Revit models.
ServerPaths are relative to the central server location, and
are of the form "RSN://{HostNodeName}/{model_path}".
The {model_path}
portion is a relative path to a Revit model. For example:
- RSN://EXS/hospital.rvt
- RSN://EXS.autodesk.com/Old Files/hotel2.rvt
- RSN://EXS.autodesk.com/Old Files/Last Week/Tuesday\hotel2.rvt
are all valid server paths.
- //EXS/Old Files/.rvt
- EXS/hospital
are not valid server paths.
If this function returns false, it does not necessarily mean
the given path is a file path. It may be a malformed string.
See Also