ChangePriority Enumeration

Enum used to specify the priority of an Updater during execution.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public enum ChangePriority
Members
Member nameValueDescription
GridsLevelsReferencePlanes0 Updater will modify core datums and major reference planes
Masses1 Updater will modify masses
FloorsRoofsStructuralWalls2 Updater will modify exterior shell of the building or floor slabs
Structure3 Updater will modify structural elements like beams, braces, columns and trusses
InteriorWalls4 Updater will modify interior/partition walls
DoorsOpeningsWindows5 Updater will modify family instances that cut their hosts like doors and windows
MEPFixtures6 Updater will modify MEP fixtures such as lights, sinks, equipment, etc.
RoomsSpacesZones7 Updater will modify Rooms, MEP spaces or zones
MEPCalculations8 Updater will update MEP calculated values
FreeStandingComponents9 Updater will modify standalone components
Connections10 Updater will modify connections
Rebar11 Updater will modify rebar
MEPAccessoriesFittingsSegmentsWires12 Updater will modify MEP elements such as segments, fittings and wires
MEPSystems13 Updater will modify MEP systems or circuits
Views14 Updater will modify views
DetailComponents15 Updater will modify detail components and symbolic lines
Annotations16 Updater will modify annotations
Remarks
The enumeration values are ordered in the order in which updaters associated to each priority will be run. For example, updaters associated to priority GridsLevelsReferencePlanes will run first, while updaters associated to priority Annotations will run last.
See Also