ReferenceConvertToStableRepresentation Method |
Converts the reference to a stable String representation.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic string ConvertToStableRepresentation(
Document document
)
Public Function ConvertToStableRepresentation (
document As Document
) As String
public:
String^ ConvertToStableRepresentation(
Document^ document
)
member ConvertToStableRepresentation :
document : Document -> string
Parameters
- document Document
- The document.
Return Value
String
Exceptions
Remarks
Examplepublic string SerializeReference(Document doc, Reference reference)
{
String ids = String.Empty;
ids = reference.ConvertToStableRepresentation(doc);
TaskDialog.Show("SerializeReference", "Representation:\n" + ids);
return ids;
}
Public Function SerializeReference(doc As Document, reference As Reference) As String
Dim ids As [String] = [String].Empty
ids = reference.ConvertToStableRepresentation(doc)
TaskDialog.Show("SerializeReference", "Representation:" & vbLf + ids)
Return ids
End Function
No code example is currently available or this language may not be supported.
No code example is currently available or this language may not be supported.
See Also