DocumentResetSharedCoordinates Method |
Reset shared coordinates for the host model/file.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void ResetSharedCoordinates()
Public Sub ResetSharedCoordinates
public:
void ResetSharedCoordinates()
member ResetSharedCoordinates : unit -> unit
ExceptionsException | Condition |
---|
InvalidOperationException |
This Document is not a primary document, it is a linked document.
-or-
This Document is not a project document.
-or-
This Document is in an edit mode.
|
ModificationForbiddenException |
The document is in failure mode: an operation has failed,
and Revit requires the user to either cancel the operation
or fix the problem (usually by deleting certain elements).
-or-
The document is being loaded, or is in the midst of another
sensitive process.
|
ModificationOutsideTransactionException |
The document has no open transaction.
|
Remarks
When you reset shared coordinates, the shared coordinates of the host model will be erased.
The shared relationship with all the linked models will be eliminated.
Survey point will be reset back to startup location, where it coincides with the Internal Origin.
The rotation angle between Project North and True North will be reset back to 0.
See Also