LinkLoadResultIsCircularLink Property |
True if these results are part of a link cycle.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool IsCircularLink { get; }
Public ReadOnly Property IsCircularLink As Boolean
Get
public:
property bool IsCircularLink {
bool get ();
}
member IsCircularLink : bool with get
Property Value
Boolean
Remarks
A link cycle occurs when, for example, model A links model B as an attachment,
which links model C as an attachment, which links model A as an attachment.
Revit will only load one copy of model A; it will ignore the instance of A linked
under C.
Circular links do not abort the load process, so they do not appear as a result type
in LinkLoadResultType.Enum.
This property is only relevant for LinkLoadResult object for RvtLinkSymbol.
ie. when getIsRvtLink() is true.
See Also