RepeaterBoundsAdjustForCyclicalBounds Method |
Shifts the input coordinates in the cyclical dimensions so that they fall in the [lower bounds, upper bounds] range.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic RepeaterCoordinates AdjustForCyclicalBounds(
RepeaterCoordinates coordinates
)
Public Function AdjustForCyclicalBounds (
coordinates As RepeaterCoordinates
) As RepeaterCoordinates
public:
RepeaterCoordinates^ AdjustForCyclicalBounds(
RepeaterCoordinates^ coordinates
)
member AdjustForCyclicalBounds :
coordinates : RepeaterCoordinates -> RepeaterCoordinates
Parameters
- coordinates RepeaterCoordinates
-
The coordinates.
Return Value
RepeaterCoordinates
The adjusted coordinates.
Exceptions
Remarks
The coordinates must have the same number of dimensions as the bounds.
This method does not apply to zero dimensional bounds.
See Also