GridSetVerticalExtents Method

Adjusts the grid to extend through only the vertical range between bottom and top.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetVerticalExtents(
	double bottom,
	double top
)

Parameters

bottom  Double
The bottom range of the grid extents. It must be a valid number and below the top range.
top  Double
The top range of the grid extents. It must be a valid number and above the bottom range.
Exceptions
ExceptionCondition
ArgumentException The bottom and top ranges are reversed for the extents.
ArgumentOutOfRangeException The given value for bottom must be no more than 30000 feet in absolute value. -or- The given value for top must be no more than 30000 feet in absolute value.
InvalidOperationException Couldn't change the extents of the grid.
See Also