SettingsElectricalSetting Property

Retrieves an object that provides access to all the electrical settings include voltage type, distribution system type, demand factor, wire type in the Autodesk Revit application and project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ElectricalSetting ElectricalSetting { get; }

Property Value

ElectricalSetting
Exceptions
ExceptionCondition
InvalidOperationException Electrical settings can be accessed only if Revit MEP product is available.
See Also