CompoundStructureSetLayerWidth Method

Sets the width of a specified layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetLayerWidth(
	int layerIdx,
	double width
)

Parameters

layerIdx  Int32
Index of a layer in the CompoundStructure.
width  Double
The new width of the specified layer.
Exceptions
ExceptionCondition
ArgumentException The width of the layer is not valid.
ArgumentOutOfRangeException The layer index is out of range.
InvalidOperationException If the region of the layer is not a simple region.
Remarks
If the structure is vertically compound, and the layer is associated to a single simple region, the width of that region is adjusted. If layerIdx is 0 or LayerCount-1, and there is no associated region in the VerticalRegionsStructure, one will be created and associated to the layer. If the specified layer index is associated to a simple region, and the width is set to 0.0, that region will be deleted.
See Also