FrameIsRightHanded Method |
Determine if this frame's basis is right-handed.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool IsRightHanded()
Public Function IsRightHanded As Boolean
public:
bool IsRightHanded()
member IsRightHanded : unit -> bool
Return Value
Boolean
True if this frame's basis is right-handed, false if not.
Remarks
The three basis vectors are "right-handed" if the triple vector product [vecX, vecY, vecZ]
is positive, or equivalently if dot(vecX x vecY, vecZ) is positive, where "dot" represents the dot product.
See Also