ParameterUserModifiable Property |
Indicates whether the interactive user can modify the value of this parameter.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool UserModifiable { get; }
Public ReadOnly Property UserModifiable As Boolean
Get
public:
property bool UserModifiable {
bool get ();
}
member UserModifiable : bool with get
Property Value
Boolean
Remarks
Note that for shared parameters IsReadOnly can return false for shared parameters whose UserModifiable property is
also false, because the value of those parameters can be modified by the API. If a parameter is governed by a formula,
IsReadOnly would return true, even if the flag for UserModifiable was set to true when the shared parameter was created.
See Also