FreeFormElementUpdateSolidGeometry Method |
Updates the geometry of the FreeForm element to the given shape preserving References to the existing geometry where possible (see remarks for rules).
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void UpdateSolidGeometry(
Solid newGeometry
)
Public Sub UpdateSolidGeometry (
newGeometry As Solid
)
public:
void UpdateSolidGeometry(
Solid^ newGeometry
)
member UpdateSolidGeometry :
newGeometry : Solid -> unit
Parameters
- newGeometry Solid
-
The new geometry to set in the FreeForm element.
Exceptions
Remarks
Rules for preserving References:
- First preserve faces as Reference when exclusively coincident with existing faces.
- Then preserve faces as Reference if exclusively parallel to existing faces.
- Then preserve faces as Reference if exclusive at small angle to the existing faces.
- Any other faces are will not be preserved as a Reference.
Edges are preserved as References if and only if exclusively bound to faces that are also preserved as References.
See Also