CustomExporter Constructor

Constructs a new instance of a CustomExporter for a given document using the input instance of IExportContext as the output device.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public CustomExporter(
	Document document,
	IExportContext context
)

Parameters

document  Document
The document containing the model to be exported
context  IExportContext
An instance of a context class that will be consuming the output
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
Remarks
The input context should be an instance of a class that implements either IModelExportContext or IPhotoRenderContext interfaces.
See Also