CompoundStructureGetPreviousNonZeroLayerIndex Method |
Returns the index of the nearest non-zero width layer before this layer.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic int GetPreviousNonZeroLayerIndex(
int thisIdx
)
Public Function GetPreviousNonZeroLayerIndex (
thisIdx As Integer
) As Integer
public:
int GetPreviousNonZeroLayerIndex(
int thisIdx
)
member GetPreviousNonZeroLayerIndex :
thisIdx : int -> int
Parameters
- thisIdx Int32
-
The layer from which to look for a non-zero width layer.
Return Value
Int32
The index of the layer found.
Remarks
If this layer is non-zero width, it will be returned. If there are non-zero width layers found, returns -1.
See Also