Transform2DTransformUVDomainIfPossible Method |
Transforms an envelope (
BoundingBoxUV) for one surface to an envelope for a coincident but differently parameterized surface.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic BoundingBoxUV TransformUVDomainIfPossible(
BoundingBoxUV uvDomain
)
Public Function TransformUVDomainIfPossible (
uvDomain As BoundingBoxUV
) As BoundingBoxUV
public:
BoundingBoxUV^ TransformUVDomainIfPossible(
BoundingBoxUV^ uvDomain
)
member TransformUVDomainIfPossible :
uvDomain : BoundingBoxUV -> BoundingBoxUV
Parameters
- uvDomain BoundingBoxUV
-
The original surface envelope.
Return Value
BoundingBoxUV
If successful a new
BoundingBoxUV transformed surface envelope, otherwise
.
Exceptions
Remarks
This method succeeds in the case when the uv-parameter transform between the surfaces
has a simple form, that commonly occurs for analytic surfaces,
such that the image of the input envelope under the transform
is itself a rectangular region aligned with the UV coordinate axes.
See Also