PerformanceAdviserAddRule Method

Adds a performance adviser rule to the list of rules.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void AddRule(
	PerformanceAdviserRuleId id,
	IPerformanceAdviserRule rule
)

Parameters

id  PerformanceAdviserRuleId
An id of the rule to be added to the list of rules.
rule  IPerformanceAdviserRule
The rule to be added
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
See Also