RebarInSystemGetBarIndexFromReference Method |
Given a reference that represents a part of a bar, this method will return the bar index.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic int GetBarIndexFromReference(
Reference barReference
)
Public Function GetBarIndexFromReference (
barReference As Reference
) As Integer
public:
int GetBarIndexFromReference(
Reference^ barReference
)
member GetBarIndexFromReference :
barReference : Reference -> int
Parameters
- barReference Reference
-
The Reference of the RebarInSystem element.
Return Value
Int32
The bar index the reference refers to.
Exceptions
Remarks
The method returns an index between 0 and NumberOfBarPositions - 1 if it the given reference represents a part of a bar.
Otherwise will return -1.
See Also