RadialDimensionCreate Method |
Creates a new instance of an Radial Dimension element within the project.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static RadialDimension Create(
Document document,
View dbView,
Reference arcRef,
bool isDiameter
)
Public Shared Function Create (
document As Document,
dbView As View,
arcRef As Reference,
isDiameter As Boolean
) As RadialDimension
public:
static RadialDimension^ Create(
Document^ document,
View^ dbView,
Reference^ arcRef,
bool isDiameter
)
static member Create :
document : Document *
dbView : View *
arcRef : Reference *
isDiameter : bool -> RadialDimension
Parameters
- document Document
-
The document where new Radial Dimension is created.
- dbView View
-
The view in which the Radial Dimension will appear.
- arcRef Reference
-
The reference which the Radial Dimension will witness.
- isDiameter Boolean
-
Set to true to create a Diameter dimension
Return Value
RadialDimension
The newly created Radial Dimension instance, or
if the operation fails.
ExceptionsException | Condition |
---|
ArgumentException |
Reference should be an Arc reference and the origin should lie within the Arc.
|
ArgumentNullException |
A non-optional argument was null
|
ModificationForbiddenException |
The document is in failure mode: an operation has failed,
and Revit requires the user to either cancel the operation
or fix the problem (usually by deleting certain elements).
-or-
The document is being loaded, or is in the midst of another
sensitive process.
|
ModificationOutsideTransactionException |
The document has no open transaction.
|
See Also