TransmissionDataWriteTransmissionData Method

Writes the given TransmissionData into the Revit file at the given location.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static void WriteTransmissionData(
	ModelPath path,
	TransmissionData data
)

Parameters

path  ModelPath
A ModelPath indicating the file Revit should write the TransmissionData of. This ModelPath must be a file path and an absolute path.
data  TransmissionData
The TransmissionData to be written into the document. Note that Revit will not check that the ElementIds in the TransmissionData correspond to real Elements.
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
FileArgumentNotFoundException There is not a valid Revit file at path's location
InvalidOperationException Operation is not valid for Revit Server models. -or- This function cannot be called on an opened document.
Remarks

This function will overwrite the existing TransmissionData in the file.

This function will not support models on Revit Server. References may be to Revit Server, but the host model must be local.

This function must be called on a closed document.

This function cannot be used to convert a reference from a local file to an external server.

See Also