RebarHostDataIsReferenceContainedByAValidHost Method |
Identifies whether an element that contains the given reference can host reinforcement.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool IsReferenceContainedByAValidHost(
Document doc,
Reference reference
)
Public Shared Function IsReferenceContainedByAValidHost (
doc As Document,
reference As Reference
) As Boolean
public:
static bool IsReferenceContainedByAValidHost(
Document^ doc,
Reference^ reference
)
static member IsReferenceContainedByAValidHost :
doc : Document *
reference : Reference -> bool
Parameters
- doc Document
-
A document.
- reference Reference
-
The reference that is part of the element that will be checked.
Return Value
Boolean
True if the input Element can host reinforcement elements,
false otherwise.
Exceptions
Remarks
Many different elements are allowed to host reinforcement,
for example, beams, walls, columns, or parts.
Often there are specific restrictions about whether an element
can host rebar beyond its type or category.
For example, the material type of the element may determine this.
Or for parts, the part must have been created from layers
that have their role set to Structure.
See Also