ParameterSet(String) Method |
Sets the parameter to a new string of text.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool Set(
string value
)
Public Function Set (
value As String
) As Boolean
public:
bool Set(
String^ value
)
member Set :
value : string -> bool
Parameters
- value String
- The new text value to which the parameter is to be set.
Return Value
BooleanThe Set method will return True if the parameter was successfully set to the new value, otherwise false.
Exceptions
RemarksYou should only use this method if the StorageType property reports the type of the
parameter as a String.
Examplevoid AddInstanceComment(Wall wall)
{
Parameter commentPara = wall.get_Parameter(BuiltInParameter.ALL_MODEL_INSTANCE_COMMENTS);
if (null != commentPara)
{
commentPara.Set("Hello Everyone.");
}
}
Private Sub AddInstanceComment(wall As Wall)
Dim commentPara As Parameter = wall.Parameter(BuiltInParameter.ALL_MODEL_INSTANCE_COMMENTS)
If commentPara IsNot Nothing Then
commentPara.[Set]("Hello Everyone.")
End If
End Sub
No code example is currently available or this language may not be supported.
No code example is currently available or this language may not be supported.
See Also