PanelScheduleDataUpdateCircuitTableForTemplate Method |
Redraw the circuit table for a template with the given parameter updates
Namespace: Autodesk.Revit.DB.ElectricalAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void UpdateCircuitTableForTemplate(
PanelSchedulePhaseLoadType newType,
int nNumSlots,
bool bPhasesAsCurrents
)
Public Sub UpdateCircuitTableForTemplate (
newType As PanelSchedulePhaseLoadType,
nNumSlots As Integer,
bPhasesAsCurrents As Boolean
)
public:
void UpdateCircuitTableForTemplate(
PanelSchedulePhaseLoadType newType,
int nNumSlots,
bool bPhasesAsCurrents
)
member UpdateCircuitTableForTemplate :
newType : PanelSchedulePhaseLoadType *
nNumSlots : int *
bPhasesAsCurrents : bool -> unit
Parameters
- newType PanelSchedulePhaseLoadType
-
The new phase load type of the circuit table
- nNumSlots Int32
-
The number of circuit slots
- bPhasesAsCurrents Boolean
-
True if the phase columns should be currents, false if they should be loads
Exceptions
See Also