PointOnPlaneNewPointOnPlane Method |
Construct a PointOnPlane given a reference and a location in space.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static PointOnPlane NewPointOnPlane(
Document doc,
Reference planeReference,
XYZ position,
XYZ xvec
)
Public Shared Function NewPointOnPlane (
doc As Document,
planeReference As Reference,
position As XYZ,
xvec As XYZ
) As PointOnPlane
public:
static PointOnPlane^ NewPointOnPlane(
Document^ doc,
Reference^ planeReference,
XYZ^ position,
XYZ^ xvec
)
static member NewPointOnPlane :
doc : Document *
planeReference : Reference *
position : XYZ *
xvec : XYZ -> PointOnPlane
Parameters
- doc Document
- The document containing the plane reference.
- planeReference Reference
-
- position XYZ
- A 3-dimensional position.
- xvec XYZ
- The direction of the point's
X-coordinate vector in the plane's
coordinates. Optional; default value is the
X-coordinate vector of the plane.
Return Value
PointOnPlaneA new PointOnPlane object with 2-dimensional Position, XVec, and Offset
properties set to match the given 3-dimensional arguments.
See Also