DuplicateTypeNamesHandlerArgs Class

A structure that provides information about an attempt to copy types with names that already exist in the destination document.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBDuplicateTypeNamesHandlerArgs

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class DuplicateTypeNamesHandlerArgs : IDisposable

The DuplicateTypeNamesHandlerArgs type exposes the following members.

Properties
 NameDescription
Public propertyDocument The document that contains the types with duplicate names.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the DuplicateTypeNamesHandlerArgs
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodGetTypeIds Returns ids of the types with duplicate names.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also