RevisionSettingsGetRevisionSettings Method

Returns the RevisionSettings for the given project document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static RevisionSettings GetRevisionSettings(
	Document ccda
)

Parameters

ccda  Document
The document to get the RevisionSettings from.

Return Value

RevisionSettings
The RevisionSettings for the document.
Exceptions
ExceptionCondition
ArgumentException ccda is not a project document.
ArgumentNullException A non-optional argument was null
See Also