RevisionsOnSheetUIServiceData Class

UI data wrapper for RevisionsOnSheetUIService.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.UIRevisionsOnSheetUIServiceData

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class RevisionsOnSheetUIServiceData : IDisposable

The RevisionsOnSheetUIServiceData type exposes the following members.

Properties
 NameDescription
Public propertyDocument return the document
Public propertyIsReset flag to indicate the value has been reset
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyParamId the parameter id
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the RevisionsOnSheetUIServiceData
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetParentHwnd return the parent handle
Public methodGetRevitElementIds return the list of revit Element Ids
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also