ArcLengthDimensionCreate Method |
Creates a new instance of an Arc Length Dimension element within the project.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static ArcLengthDimension Create(
Document document,
View dbView,
Arc arc,
Reference ArcRef,
IList<Reference> references
)
Public Shared Function Create (
document As Document,
dbView As View,
arc As Arc,
ArcRef As Reference,
references As IList(Of Reference)
) As ArcLengthDimension
public:
static ArcLengthDimension^ Create(
Document^ document,
View^ dbView,
Arc^ arc,
Reference^ ArcRef,
IList<Reference^>^ references
)
static member Create :
document : Document *
dbView : View *
arc : Arc *
ArcRef : Reference *
references : IList<Reference> -> ArcLengthDimension
Parameters
- document Document
-
The document where the new Arc Length Dimension is created.
- dbView View
-
The view in which the Arc Length Dimension will appear.
- arc Arc
-
The Arc of the annotation itself
- ArcRef Reference
-
Reference for the arc to be measured
- references IListReference
-
The segments which the Arc Length Dimension will witness.
Return Value
ArcLengthDimension
The newly created Arc Length Dimension instance, or
if the operation fails.
ExceptionsException | Condition |
---|
ArgumentException |
References should be: at least two and intersecting the ends of the arc passed.
|
ArgumentNullException |
A non-optional argument was null
|
ModificationForbiddenException |
The document is in failure mode: an operation has failed,
and Revit requires the user to either cancel the operation
or fix the problem (usually by deleting certain elements).
-or-
The document is being loaded, or is in the midst of another
sensitive process.
|
ModificationOutsideTransactionException |
The document has no open transaction.
|
See Also