IndependentTagRemoveReferences Method |
Removes the provided list of references from the tag's list of references.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void RemoveReferences(
IList<Reference> referencesToRemove
)
Public Sub RemoveReferences (
referencesToRemove As IList(Of Reference)
)
public:
void RemoveReferences(
IList<Reference^>^ referencesToRemove
)
member RemoveReferences :
referencesToRemove : IList<Reference> -> unit
Parameters
- referencesToRemove IListReference
-
References to be removed from tag.
ExceptionsException | Condition |
---|
ArgumentException |
The operation failed. Please verify that the references are all tagged before removing them.
|
ArgumentNullException |
A non-optional argument was null
|
InvalidOperationException |
The IndependentTag object does not have a tag behavior.
-or-
Modifying tag references for MRA owned tag from API is not allowed.
|
Remarks
If the tag is owned by MRA element, an exception will be thrown.
See Also