GlobalParameterHasValidTypeForReporting Method |
Tests that the global parameter has data of a type that supports reporting.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool HasValidTypeForReporting()
Public Function HasValidTypeForReporting As Boolean
public:
bool HasValidTypeForReporting()
member HasValidTypeForReporting : unit -> bool
Return Value
Boolean
True if the parameter has data of a type that supports reporting; False otherwise.
Remarks
Only few data types can be used for reporting parmeters. Currently, reporting
global parameters must be either of type Lenght or Angle -
basically, they need to be value-driven by standard dimensions.
See Also