LinearDimensionCreate Method |
Creates a new instance of an Linear Dimension element within the project.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static LinearDimension Create(
Document document,
View dbView,
Line line,
IList<Reference> references
)
Public Shared Function Create (
document As Document,
dbView As View,
line As Line,
references As IList(Of Reference)
) As LinearDimension
public:
static LinearDimension^ Create(
Document^ document,
View^ dbView,
Line^ line,
IList<Reference^>^ references
)
static member Create :
document : Document *
dbView : View *
line : Line *
references : IList<Reference> -> LinearDimension
Parameters
- document Document
-
The document where new Linear Dimension is created.
- dbView View
-
The view in which the Linear Dimension will appear.
- line Line
-
The line of the annotation
- references IListReference
-
references that the Linear Dimension will witness.
Return Value
LinearDimension
The newly created Linear Dimension instance, or
if the operation fails.
Exceptions
See Also