DistributionOfNormals Enumeration

An enumeration containing the choices of how normal vectors are assigned and distributed along the surface of a polymesh. Planar faces would typically have only normal vector associated, but curved faces can have a different normal either for each facet (triangle) or each point of the tessellated polymesh.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public enum DistributionOfNormals
Members
Member nameValueDescription
AtEachPoint0 One normal vector is assigned to each vertex of the polymesh.
OnePerFace1 There is only one common normal vector assigned to the face/polymesh.
OnEachFacet2 There is one normal vector per each facet of the polymesh.
See Also