RebarSpliceGeometry Constructor

Constructs a RebarSpliceGeometry.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public RebarSpliceGeometry(
	XYZ spliceOrigin,
	XYZ spliceNormal
)

Parameters

spliceOrigin  XYZ
The splice face origin.
spliceNormal  XYZ
The splice face normal.
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException spliceNormal has zero length.
See Also