TransformCreateRotationAtPoint Method |
Creates a transform that represents a rotation about the given axis at the specified point.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static Transform CreateRotationAtPoint(
XYZ axis,
double angle,
XYZ origin
)
Public Shared Function CreateRotationAtPoint (
axis As XYZ,
angle As Double,
origin As XYZ
) As Transform
public:
static Transform^ CreateRotationAtPoint(
XYZ^ axis,
double angle,
XYZ^ origin
)
static member CreateRotationAtPoint :
axis : XYZ *
angle : float *
origin : XYZ -> Transform
Parameters
- axis XYZ
-
The rotation axis.
- angle Double
-
The angle.
- origin XYZ
-
The origin point.
Return Value
Transform
The new transform.
Exceptions
See Also