LocationPointPoint Property |
The physical location of the element.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic XYZ Point { get; set; }
Public Property Point As XYZ
Get
Set
public:
property XYZ^ Point {
XYZ^ get ();
void set (XYZ^ value);
}
member Point : XYZ with get, set
Property Value
XYZ
RemarksSetting this property is not supported for
some elements supporting LocationPoints, such as SpotDimensions.
Examplevoid LocationMove(FamilyInstance column)
{
LocationPoint columnPoint = column.Location as LocationPoint;
if (null != columnPoint)
{
XYZ newLocation = new XYZ(10, 20, 0);
columnPoint.Point = newLocation;
}
}
Private Sub LocationMove(column As FamilyInstance)
Dim columnPoint As LocationPoint = TryCast(column.Location, LocationPoint)
If columnPoint IsNot Nothing Then
Dim newLocation As New XYZ(10, 20, 0)
columnPoint.Point = newLocation
End If
End Sub
No code example is currently available or this language may not be supported.
No code example is currently available or this language may not be supported.
See Also