DirectShapeSetShape(IListGeometryObject) Method |
Builds the shape of this object from the supplied collection of GeometryObjects. The objects are copied.
If the new shape is identical to the old one, the old shape will be kept.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetShape(
IList<GeometryObject> pGeomArr
)
Public Sub SetShape (
pGeomArr As IList(Of GeometryObject)
)
public:
void SetShape(
IList<GeometryObject^>^ pGeomArr
)
member SetShape :
pGeomArr : IList<GeometryObject> -> unit
Parameters
- pGeomArr IListGeometryObject
-
Shape of this object expressed as a collection of GeometryObjects.
The supported types of GeometryObjects are: Solid, Mesh, GeometryInstance, Point and Curve.
Exceptions
See Also