PropOverrideMode Enumeration

An enumerated type listing ways how overridden object styles get exported.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public enum PropOverrideMode
Members
Member nameValueDescription
ByEntity0 Category properties BYLAYER, overrides BYENTITY. Entities generated by a specific category are assigned to a layer accordingly to the layer settings. To preserve visual fidelity, overridden attributes result in entity-specific attributes
ByLayer1 All properties BYLAYER, no overrides Forces all entities to follow visual properties as set by their layer. Visual fidelity is lost, but this produces the least number of layers while still providing by-layer control over exported entities.
NewLayer2 All properties BYLAYER, New Layers for overrides. Visual fidelity is preserved and there is by-layer control over all entities, although number of layers in the exported file might be increased.
See Also