FailuresProcessingEventArgsSetProcessingResult Method

Sets the result of the failures processing accomplished during this event callback.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetProcessingResult(
	FailureProcessingResult result
)

Parameters

result  FailureProcessingResult
The result.
Exceptions
ExceptionCondition
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
Remarks

If this value is not explicitly set, the default value (Continue) will be used. If the event callback is resolving errors explicitly, it must be set to ProceedWithCommit - see the remarks for the FailuresProcessingEventArgs object for more details.

Note that ProceedWithCommit should not be set if the handler has not resolved any errors - the handler will be called again as a result of the commit request and Revit failure handling will never be reached.

Setting this result may not affect the outcome if other observers of the event are invoked after this one. The most prohibitive result set by all handlers will be used.

See Also