AutomaticConnectionBehaviorType Enumeration |
Defines behavior of connector with respect to automatic creation of connections
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic enum AutomaticConnectionBehaviorType
Public Enumeration AutomaticConnectionBehaviorType
public enum class AutomaticConnectionBehaviorType
type AutomaticConnectionBehaviorType
MembersMember name | Value | Description |
---|
Exclude | 0 |
Connector does not participate in automatic connection
|
Active | 1 |
Connector is actively looking to be connected
|
Forced | 2 |
Connector must establish a connection
|
Accepting | 3 |
Connector accepts more automatic connections if needed, but
|
Full | 4 |
Connector may participate in automatic connection, but at the moment it is fully connected
|
See Also