BRepBuilderCanAddGeometry Method |
A validator function that checks the state of this BRepBuilder object. Returns true if this BRepBuilder object is accepting b-rep data, false otherwise.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool CanAddGeometry()
Public Function CanAddGeometry As Boolean
public:
bool CanAddGeometry()
member CanAddGeometry : unit -> bool
Return Value
Boolean
True if this BRepBuilder object is accepting b-rep data, false otherwise.
Remarks
Use this function before calling AddFace(), AddEdge(), etc. to avoid an exception being thrown.
See Also