CompoundStructureSetNumberOfShellLayers Method |
Sets the number of interior or exterior shell layers.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetNumberOfShellLayers(
ShellLayerType shellLayerType,
int numLayers
)
Public Sub SetNumberOfShellLayers (
shellLayerType As ShellLayerType,
numLayers As Integer
)
public:
void SetNumberOfShellLayers(
ShellLayerType shellLayerType,
int numLayers
)
member SetNumberOfShellLayers :
shellLayerType : ShellLayerType *
numLayers : int -> unit
Parameters
- shellLayerType ShellLayerType
-
If ShellLayerType.Exterior set the number of exterior shell layers (or top shell layers for a roof, floor, or ceiling type).
If ShellLayerType.Interior set the number of interior shell layers (or bottom shell layers for a roof, floor, or ceiling type).
- numLayers Int32
-
The number of layers to be in the specified shell.
Exceptions
Remarks
There must be at least one core layer, i.e. one layer which is not a shell layer.
See Also